Wednesday, 14 January 2015

Sitecore Experience Platform (SXP) 8: Software and Hardware Requirements

The new Sitecore Experience Platform (SXP) 8 has lot of changes from the previous Sitecore version. There is a need of latest Software and Hardware to run a new SXP instance. The detailed explanation is available in dev.sitecore.net. Here is the quick overview of the requirements.

Requirements for Sitecore Experience Platform:

Internet Information Services (IIS):
  • IIS 8.5
  • IIS 8.0
  • IIS 7.5
  • IIS 7.0

Operating System (OS):
  • Windows Server 2012 R2 (64-bit)
  • Windows Server 2012 (64-bit)
  • Windows Server 2008 R2 (64-bit) SP1+
  • Windows Server 2008 (32/64-bit) SP2+
  • Windows Vista (32/64-bit) SP2+ (Business, Ultimate, Enterprise)
  • Windows 8.1 (32/64-bit) (Enterprise, Professional, Core)
  • Windows 8 (32/64-bit) (Enterprise, Professional, Core)
  • Windows 7 (32/64-bit, Home Premium and higher) SP1+ (Ultimate, Enterprise, Professional)

.NET Framework:
  • .NET Framework 4.5

Visual Studio:
  • Visual Studio 2012 or later

Database: (supports corresponding express edition)
  • Microsoft SQL Server 2008 R2 SP1
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2014
  • MongoDB Database 2.6.1 or later (for Sitecore xDB)

Hardware:
  • Minimum: 4 core processor (4 threads), 8GB of RAM
  • Recommended by Sitecore: 4 core processor (8 threads), 16GB of RAM

Articles

Automatically create new version for Lock & Edit without workflow

Sitecore will create a new version on Lock and Edit if the item is tied to a workflow. For our case, version has to be created even withou...